Website Outage

Incident Report for BeachWalk Cafe

Resolved

Roblox has now fixed the issue, thanks everyone for your patience. Enjoy!
Posted May 05, 2022 - 07:41 AEST

Update

Roblox should be back up later, thanks everyone for your patience!
Posted May 04, 2022 - 17:23 AEST

Update

We are continuing to monitor for any further issues.
Posted May 04, 2022 - 16:16 AEST

Monitoring

The Roblox website is currently down, please give Roblox some time to fix it, they are working hard to fix it at the moment.
Posted May 04, 2022 - 16:10 AEST
This incident affected: BeachWalk Cafe, Application Centre, Roblox Group, Event Centre, and Support Centre.