Everything's back up and running, thanks for your patience everyone!
Posted May 08, 2022 - 15:49 AEST
Identified
All game except the café is now on hold, we don't know what is happening if it is on Roblox's side or just our games. Please give us some time to fix it, thanks for your patience everyone!
Posted May 08, 2022 - 09:51 AEST
This incident affected: BeachWalk Cafe, Application Centre, Training Centre, Event Centre, Support Centre, and BeachWalk Website.